We are currently experiencing a service disruption affecting device communications

Incident Report for RACO Mfg and Eng Co

Resolved

This incident has been resolved.
Posted Mar 28, 2026 - 15:53 PDT

Monitoring

All services have been restored. We are continuing to monitor the system to ensure full stability and normal operation.

Thank you for your patience while we resolved the issue.
Posted Mar 28, 2026 - 07:39 PDT

Investigating

Our engineering team has identified that backend message handlers became overloaded, which slowed message processing and prevented timely acknowledgements to RTUs. As a result, devices began retrying transmissions, increasing message volume and further compounding the issue.

We are actively working to process and acknowledge queued messages to stabilize traffic and restore normal operation.

We will continue to provide updates as progress is made. Thank you for your patience.
Posted Mar 28, 2026 - 07:18 PDT
This incident affected: Web Services (AlarmAgent Server Health, AlarmAgent Web Site Health, AlarmAgent Reports, AlarmAgent.Info), Alarm Notification Services (AlarmAgent Email Health, AlarmAgent SMS Health, AlarmAgent Voice System Health), and Wireless Communication Services (AlarmAgent LTE Cellular Data Health, RTU Firmware v5+ Data Processing).