Our provider's engineering team continues to investigate the connectivity issue affecting cellular data services. Additional escalation steps have been taken. No estimated time to resolution is available at this time. The scope of impact has expanded slightly since our initial notice. SMS delivery is now also reporting degraded performance in addition to cellular data, across US and global networks. We will continue to post updates here as new information becomes available.
Posted Jun 22, 2026 - 10:14 PDT
Investigating
We are currently experiencing a service disruption affecting cellular data connectivity for devices on our network. This is the result of an ongoing issue with our upstream connectivity provider, which is actively working to restore service. VPN tunnels and AlarmAgent data ingestion are impacted.
Affected services include cellular data transmission for devices on LTE and Fusion networks.
We have an open support case with our provider and will post updates here as new information becomes available. We apologize for the inconvenience and will continue to provide updates as the situation develops.
Posted Jun 22, 2026 - 08:39 PDT
This incident affects: Wireless Communication Services (AlarmAgent LTE Cellular Data Health).